Debian Jessie – Kernel 4.2 aus Backports installieren

Den Kernel aus den Backports zu installieren macht bei aktuellen Systemen mit neuen Prozessoren, Mainboards uvm. Sinn. In meinem Fall wollte ich ausprobieren, ob der Treiber für einen Marvell Chip „besser“ funktioniert. Nachfolgend eine kurze Anleitung.

Im übrigen braucht man seit Wheezy keine Angst mehr haben ungewohlt ein Paket aus den Backports zu installieren. Die Backports werden nun mit der Priorität 100 gepinnt. D.h. man muss schon explizit das Paket angeben, was man aus den Backports installieren möchte (-t wheezy-backports).

Status – Welcher Kernel ist installiert?

# uname -r
-> 3.16.0-4-amd64

1. zuerst passe ich die /etc/apt/sources.list an und füge folgende Zeilen hinzu

deb http://http.debian.net/debian jessie-backports main

oder für unfreie Programme, Treiber und Addons :

deb http://ftp.de.debian.org/debian/ jessie-backports main contrib non-free

2. den Paketspeicher aktualisieren: # aptitude-update

3. nach dem neusten verfügbaren Kernel schauen: # apt-cache search -t jessie-backports linux-image
-> linux-image-4.2.0-0.bpo.1-amd64

4. ebenso die passenden Header installieren, ist z.B. für Virtualbox wichtig): # apt-cache search linux-headers
-> linux-headers-4.2.0-0.bpo.1-amd64

5. beides installieren: # aptitude install linux-image-4.2.0-0.bpo.1-amd64 linux-headers-4.2.0-0.bpo.1-amd64

oder direkt die backports angeben:

# aptitude install -t jessie-backports install linux-image-amd64

6. Systemneustart: #reboot

7. Version des Kernel prüfen:  # uname -r
4.2-0.bpo.2-amd64

Somit ist das Kernelupgrade auf Version 4.2 aus den Backports für Jessie geglückt.

Hinweis für mich wegen Root und Boot auf Mdadm Raid: vor dem Neustart noch # update-grub und update-initramfs -ck all ausgeführt.

2 thoughts on “Debian Jessie – Kernel 4.2 aus Backports installieren

  1. Andre

    Tja, Du Glückspilz. Bei mir hat es nicht funktioniert, hier:
    apt-get install linux-image-4.7.0-0.bpo.1-amd64 linux-headers-4.7.0-0.bpo.1-amd64

    Die folgenden Pakete haben unerfüllte Abhängigkeiten:
    linux-image-4.7.0-0.bpo.1-amd64 : Hängt ab von: linux-base (>= 4.3~) aber 3.5 soll installiert werden
    E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

    Reply

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.