Proxmox VE – Detected Hardware Unit Hang

      Keine Kommentare zu Proxmox VE – Detected Hardware Unit Hang

Seit der Proxmox VE 5.x Version gibt es bei einigen Probleme mit dem Kernel und speziell mit der Netzwerkkarte. Meistens eine Intel (VE1000). Das Problem das auch meine Server betrifft stellt sich so da, dass die Netzwerkverbindung plötzlich abbricht und kurze Zeit später wieder korrekt funktioniert. Das Ganze passiert recht sporadisch und kann auch mal ein paar Tage gut gehen. Bei mir war es immer unter höherem Load der Netzwerkkarte. Im Log ist dieser Fehler zu sehen:

“e1000e : Detected Hardware Unit Hang”

Die einzige Lösung die ich bisher gefunden habe, dank der Community von Proxmox VE ist diese, ausgehend es ist eine Netzwerkkarte verbaut die mit eth0 bezeichnet wird:

# nano /etc/network/interfaces

auto eth0
iface eth2 inet manual
offload-tx off

offload-sg off
offload-tso off
post-up /sbin/ethtool -K eth0 tx off rx off

Kontrolle ist mittels # ethtool -i eth0 durchführbar. Infos zu den Optionen unter: https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/6/html/performance_tuning_guide/network-nic-offloads

Danach kann der Server neugestartet werden und die Einstellungen bleiben erhalten und es kommt zu keinen Netzwerkabbrüchen mehr.

Have Fun …

 

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.