Zabbix unsupported MariaDB Database Version

Ich habe auf einem Debian Buster (11) den Zabbix Server mit der zusätzlichen Sourcelist von Zabbix in Version 5.5 installiert. Die benötigte MariaDB kommt über die Debian Sourcen und wurde in Version 10.3 installiert. Nach einem Update von Zabbix auf 5.5.1 startet der Dienst nicht mehr.

Fehlermeldung laut syslog:

Unable to start Zabbix server due to unsupported MariaDB database server version (10.03.29)
   568:20211005:082800.340 Must be at least (10.05.00)
Override by setting AllowUnsupportedDBVersions=1 in Zabbix server configuration file at your own risk.

Um das Versionsproblem zu lösen, habe ich in der /etc/zabbix/zabbix_server.conf die laut Fehlermeldung genannte Option im Abschnitt DBHost hinzugefügt:

AllowUnsupportedDBVersions=1

Danach habe ich das System neugestartet und der Zabbix Server lief wieder.

Schreibe einen Kommentar

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.