moodle in Version 3.2.1 – 3.1.4 – 3.0.8 und 2.7.18 veröffentlicht

Die freie Lernplattform und Kursmanagementsystem, moodle, wurde Anfang Januar aktualisiert und ist nun in den Versionen 3.2.1, 3.1.4, 3.0.8 und 2.7.18 erhältlich. Neben zahlreichen Bugs wurden auch Sicherheitsfixe durchgeführt.

moodle 3.2.1 Release Notes

Fixes and improvements

  • MDL-55906 – Assignment grading table reset button should clear persistent settings
  • MDL-57222 – Marking workflow and grading must still save for hidden Assignment
  • MDL-56810 – Fixed error converting submissions for annotation when student is unenrolled from course
  • MDL-55062 – Upload users admin tool incorrectly updates authentication method for existing users when not included in CSV
  • MDL-56912 – Feedback: Allow to submit empty not required multichoice questions
  • MDL-53044 – Completely prevent login with expired passwords
  • MDL-57213 – Boost – Fixed bug when my courses were not displayed at all with $CFG->navshowmycoursecategories on

Security issues

  • MSA-17-0001 System file inclusion when adding own preset file in Boost theme
  • MSA-17-0002 Incorrect sanitation of attributes in forums
  • MSA-17-0003 PHPMailer vulnerability in no-reply address
  • MSA-17-0004 XSS in assignment submission page

https://docs.moodle.org/dev/Moodle_3.2.1_release_notes

moodle 3.1.4 Release Notes

Fixes and improvements

  • MDL-42977 – Improve Collapse/Expand behavior on the course listing page
  • MDL-48055 – Outline report (at the student Activity reports) no longer shows quiz grade when it must be hidden
  • MDL-55906 – Assignment grading table reset button should clear persistent settings
  • MDL-57222 – Marking workflow and grading must still save for hidden Assignment
  • MDL-56810 – Fixed error converting submissions for annotation when student is unenrolled from course
  • MDL-54846 – Add support for embedding WAVE (.wav) files
  • MDL-55062 – Upload users admin tool incorrectly updates authentication method for existing users when not included in CSV
  • MDL-56912 – Feedback: Allow to submit empty not required multichoice questions
  • MDL-53044 – Completely prevent login with expired passwords

Security issues

https://docs.moodle.org/dev/Moodle_3.1.4_release_notes

moodle 3.0.8 Release Notes

Security issues

https://docs.moodle.org/dev/Moodle_3.0.8_release_notes

moodle 2.7.18  Release Notes

Security issues

Security issues

https://docs.moodle.org/dev/Moodle_2.7.18_release_notes

moodle Long Term Support (LTS)

Wie in der Grafik des Supports der Branches zu sehen, ist moodle in dne Zeigen 2.7.x, 2.9.x und 3.0.x nicht mehr im Support. Sie erhalten lediglich die Security Updates.

moodle LTS bis 2019

moodle LTS bis 2019

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.