Zabbix Logo

Zabbix Agent – Dienst startet nicht beim Serverstart

Ich habe auf einem Debian Stretch den Zabbix Agent laufen. Dieser startet jedoch nicht beim Start des Systems.

# systemctl status zabbix-agent.service 
● zabbix-agent.service - Zabbix Agent
   Loaded: loaded (/lib/systemd/system/zabbix-agent.service; disabled; vendor preset: enabled)
   Active: inactive (dead)

Wird der Agent von Hand gestartet sieht alles gut aus und er läuft auch normal.

# systemctl start zabbix-agent.service 
# systemctl status zabbix-agent.service 
● zabbix-agent.service - Zabbix Agent
   Loaded: loaded (/lib/systemd/system/zabbix-agent.service; disabled; vendor preset: enabled)
   Active: active (running) since Wed 2019-11-20 11:14:02 CET; 7s ago
  Process: 5013 ExecStart=/usr/sbin/zabbix_agentd -c $CONFFILE (code=exited, status=0/SUCCESS)
 Main PID: 5015 (zabbix_agentd)
    Tasks: 6 (limit: 4915)
   Memory: 5.6M
      CPU: 75ms
   CGroup: /system.slice/zabbix-agent.service
           ├─5015 /usr/sbin/zabbix_agentd -c /etc/zabbix/zabbix_agentd.conf
           ├─5016 /usr/sbin/zabbix_agentd: collector [idle 1 sec]
           ├─5017 /usr/sbin/zabbix_agentd: listener #1 [waiting for connection]
           ├─5018 /usr/sbin/zabbix_agentd: listener #2 [waiting for connection]
           ├─5019 /usr/sbin/zabbix_agentd: listener #3 [waiting for connection]
           └─5020 /usr/sbin/zabbix_agentd: active checks #1 [idle 1 sec]

Damit der Agent nun auch beim booten des Systems automatisch startet, ist folgendes auszuführen:

# systemctl enable zabbix-agent.service

Hintergrund ist, dass Debian Stretch systemd und nicht die init.d nutzt.

Have Fun ..

Schreibe einen Kommentar

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.