OPNsense 21.1.8 Bugfix und PHP 7.4 Release

Die Entwickler der Open-Source Firewall, OPNsense, haben vor wenigen Tagen das Bugfix Release 21.1.8 veröffentlicht. Das Update bringt PHP 7.4, eine Übersetzung in norwegisch und einige Fehlerkorrekturen, mit.

OPNsense 21.1.8 Release Notes

  • system: Norwegian translation (contributed by Stein-Aksel Basma)
  • system: correctly enforce “Disable writing log files to the local disk” when circular logs are not used
  • system: allow to edit gateway entries with non-conforming names
  • system: add HA sync entry for live log templates
  • system: lock config writes during HA merges
  • interfaces: do not check for existing CARP interfaces midstream
  • interfaces: refactor IP address removal on configure
  • interfaces: remove non-tunnel restriction from address collection
  • interfaces: set tunnel flag for IPv4 tunnel plus cleanups
  • firewall: possibility to filter nat/rdr action in live log
  • firewall: set label for obsolete rule in live log (contributed by kulikov-a)
  • intrusion detection: fix alert reads from eve.json
  • ui: prevent translation line breaks from breaking JS
  • ui: switch firewall category icon for clarity
  • plugins: os-etpro-telemetry 1.5 exclude stale data from telemetry upload
  • plugins: os-fetchmail 1.0 (contributed by Michael Muenz)
  • plugins: os-freeradius 1.9.14[1]
  • plugins: os-maltrail 1.8[2]
  • plugins: os-nginx Phalcon 4 fixes
  • plugins: os-nut 1.8[3]
  • plugins: os-telegraf 1.11.0[4]
  • plugins: os-tor Phalcon 4 fix
  • plugins: os-zabbix5-proxy is now a plugin variant
  • src: libcasper: fix descriptors numbers[5]
  • src: linux: Prevent integer overflow in futex_requeue[6]
  • ports: clog 1.0.2 fixes garbage header write on init
  • ports: libxml 2.9.12[7]
  • ports: nettle 3.7.3
  • ports: nss 3.67[8]
  • ports: openvpn 2.5.3[9]
  • ports: php 7.4.20[10]
  • ports: phpseclib 2.0.32[11]
  • ports: sudo 1.9.7p1[12]
  • ports: suricata 5.0.7[13]

A hotfix release was issued as 21.1.8_1:

  • system: fix PHP 7.4 deprecated warning in IPv6 library

Schreibe einen Kommentar

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.